summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-01 12:44:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-01 12:46:19 +0200
commit9b1a2dcd5be13c89efff8c448c1a861d81d221ed (patch)
treeb3bf39b369ccde6f4b8ab5bc5109c9a70ce5e5f0 /gnu/packages/machine-learning.scm
parenta69f2cd0769d2f1323773dfb921c527037e9d5ce (diff)
downloadguix-patches-9b1a2dcd5be13c89efff8c448c1a861d81d221ed.tar
guix-patches-9b1a2dcd5be13c89efff8c448c1a861d81d221ed.tar.gz
gnu: python-umap-learn: Disable unreliable test.
* gnu/packages/machine-learning.scm (python-umap-learn)[arguments]: Disable test_densmap_trustworthiness_on_iris_supervised.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1f85aa290f..cd0640cd27 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2758,7 +2758,10 @@ These include a barrier, broadcast, and allreduce.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "HOME" "/tmp")
- (invoke "pytest" "-vv" "umap")))))))
+ (invoke "pytest" "-vv" "umap"
+ ;; This test can fail because trust may only be
+ ;; 0.9679405204460967 >= 0.97
+ "-k" "not test_densmap_trustworthiness_on_iris_supervised")))))))
(native-inputs (list python-pytest))
(propagated-inputs
(list python-numba