summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-01 10:36:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-01 11:19:52 +0200
commit8f1ab4fb4192dc91814c0c0f45cc7a279ff8a334 (patch)
treef20b42adf8e9bccd57f48c5d0bb207d8337b3bc5 /gnu/packages/machine-learning.scm
parentd2a9a39c718f8595c68592c99bec56013a0653fb (diff)
downloadguix-patches-8f1ab4fb4192dc91814c0c0f45cc7a279ff8a334.tar
guix-patches-8f1ab4fb4192dc91814c0c0f45cc7a279ff8a334.tar.gz
gnu: Move some lisp libraries.
Move the 3 lisp libraries that are not in lisp-xyz.scm with the others. * gnu/packages/machine-learning.scm (sbcl-cl-libsvm-format, cl-libsvm-format, ecl-cl-libsvm-format, sbcl-cl-online-learning, cl-online-learning, ecl-cl-online-learning, sbcl-cl-random-forest, cl-random-forest, ecl-cl-random-forest): Move to ... * gnu/packages/lisp-xyz.scm (sbcl-cl-libsvm-format, cl-libsvm-format, ecl-cl-libsvm-format, sbcl-cl-online-learning, cl-online-learning, ecl-cl-online-learning, sbcl-cl-random-forest, cl-random-forest, ecl-cl-random-forest): ... here.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm118
1 files changed, 0 insertions, 118 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 0c02fbcfc7..d6a1064683 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -37,7 +37,6 @@
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix svn-download)
- #:use-module (guix build-system asdf)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
@@ -63,7 +62,6 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
- #:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ocaml)
@@ -1965,122 +1963,6 @@ that:
@end itemize\n")
(license license:expat)))
-(define-public sbcl-cl-libsvm-format
- (let ((commit "3300f84fd8d9f5beafc114f543f9d83417c742fb")
- (revision "0"))
- (package
- (name "sbcl-cl-libsvm-format")
- (version (git-version "0.1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/masatoi/cl-libsvm-format.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0284aj84xszhkhlivaigf9qj855fxad3mzmv3zfr0qzb5k0nzwrg"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("prove" ,sbcl-prove)
- ("prove-asdf" ,sbcl-prove-asdf)))
- (inputs
- `(("alexandria" ,sbcl-alexandria)))
- (synopsis "LibSVM data format reader for Common Lisp")
- (description
- "This Common Lisp library provides a fast reader for data in LibSVM
-format.")
- (home-page "https://github.com/masatoi/cl-libsvm-format")
- (license license:expat))))
-
-(define-public cl-libsvm-format
- (sbcl-package->cl-source-package sbcl-cl-libsvm-format))
-
-(define-public ecl-cl-libsvm-format
- (sbcl-package->ecl-package sbcl-cl-libsvm-format))
-
-(define-public sbcl-cl-online-learning
- (let ((commit "fc7a34f4f161cd1c7dd747d2ed8f698947781423")
- (revision "0"))
- (package
- (name "sbcl-cl-online-learning")
- (version (git-version "0.5" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/masatoi/cl-online-learning.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14x95rlg80ay5hv645ki57pqvy12v28hz4k1w0f6bsfi2rmpxchq"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("prove" ,sbcl-prove)
- ("prove-asdf" ,sbcl-prove-asdf)))
- (inputs
- `(("cl-libsvm-format" ,sbcl-cl-libsvm-format)
- ("cl-store" ,sbcl-cl-store)))
- (arguments
- `(;; FIXME: Tests pass but then the check phase crashes
- #:tests? #f))
- (synopsis "Online Machine Learning for Common Lisp")
- (description
- "This library contains a collection of machine learning algorithms for
-online linear classification written in Common Lisp.")
- (home-page "https://github.com/masatoi/cl-online-learning")
- (license license:expat))))
-
-(define-public cl-online-learning
- (sbcl-package->cl-source-package sbcl-cl-online-learning))
-
-(define-public ecl-cl-online-learning
- (sbcl-package->ecl-package sbcl-cl-online-learning))
-
-(define-public sbcl-cl-random-forest
- (let ((commit "85fbdd4596d40e824f70f1b7cf239cf544e49d51")
- (revision "0"))
- (package
- (name "sbcl-cl-random-forest")
- (version (git-version "0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/masatoi/cl-random-forest.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "097xv60i1ndz68sg9p4pc7c5gvyp9i1xgw966b4wwfq3x6hbz421"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("prove" ,sbcl-prove)
- ("prove-asdf" ,sbcl-prove-asdf)
- ("trivial-garbage" ,sbcl-trivial-garbage)))
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("cl-libsvm-format" ,sbcl-cl-libsvm-format)
- ("cl-online-learning" ,sbcl-cl-online-learning)
- ("lparallel" ,sbcl-lparallel)))
- (arguments
- `(#:tests? #f)) ; The tests download data from the Internet
- (synopsis "Random Forest and Global Refinement for Common Lisp")
- (description
- "CL-random-forest is an implementation of Random Forest for multiclass
-classification and univariate regression written in Common Lisp. It also
-includes an implementation of Global Refinement of Random Forest.")
- (home-page "https://github.com/masatoi/cl-random-forest")
- (license license:expat))))
-
-(define-public cl-random-forest
- (sbcl-package->cl-source-package sbcl-cl-random-forest))
-
-(define-public ecl-cl-random-forest
- (sbcl-package->ecl-package sbcl-cl-random-forest))
-
(define-public gloo
(let ((version "0.0.0") ; no proper version tag
(commit "ca528e32fea9ca8f2b16053cff17160290fc84ce")