summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-11 23:42:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:29 -0500
commit8b11b4a8297bffa8ee773e9dae763a80d3cde68d (patch)
tree03f83f61fa49ce4527d8057013b6f9be8f427db2 /gnu/packages/machine-learning.scm
parent7b38a968296ce238596b294601820bdf1d2b2530 (diff)
downloadguix-patches-8b11b4a8297bffa8ee773e9dae763a80d3cde68d.tar
guix-patches-8b11b4a8297bffa8ee773e9dae763a80d3cde68d.tar.gz
gnu: python-keras: Skip a flaky test.
* gnu/packages/machine-learning.scm (python-keras) [phases]{check}: Also skip the test_stateful_metrics test.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 85460aebfb..88ce23c410 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2538,9 +2538,14 @@ with image data, text data, and sequence data.")
"-p" "no:pep8"
;; FIXME: python-build-system lacks PARALLEL-TESTS?
"-n" (number->string (parallel-job-count))
- ;; The following test fail only in the build container;
- ;; skip it.
- "-k" "not test_selu")))))))
+ "-k"
+ (string-append
+ ;; The following test fails only in the build
+ ;; container; skip it.
+ "not test_selu "
+ ;; The following test was found flaky and removed in
+ ;; recent versions.
+ "and not test_stateful_metrics"))))))))
(propagated-inputs
`(("python-h5py" ,python-h5py)
("python-keras-applications" ,python-keras-applications)