summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-09-25 19:36:50 +0000
committerLeo Famulari <leo@famulari.name>2021-09-25 16:06:28 -0400
commit6e5e60a20c7e327e6d0d672bfdaaf85d45a70f5f (patch)
tree6d50b6deb48169437a8603d64d8ad4bf15531784 /gnu/packages/machine-learning.scm
parent7e73fc3bb98bdc5f615684c5cedf3c7212afe28a (diff)
downloadguix-patches-6e5e60a20c7e327e6d0d672bfdaaf85d45a70f5f.tar
guix-patches-6e5e60a20c7e327e6d0d672bfdaaf85d45a70f5f.tar.gz
gnu: Add xgboost.
* gnu/packages/machine-learning.scm (xgboost): New variable. * gnu/packages/patches/xgboost-use-system-dmlc-core.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a4768211a0..454088b1a5 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2338,6 +2338,38 @@ offers the bricks to build efficient and scalable distributed machine
learning libraries.")
(license license:asl2.0)))
+(define-public xgboost
+ (package
+ (name "xgboost")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmlc/xgboost")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (patches (search-patches "xgboost-use-system-dmlc-core.patch"))
+ (sha256
+ (base32 "00liz816ahk9zj3jv3m2fqwlf6xxfbgvpmpl72iklx32vl192w5d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DGOOGLE_TEST=ON")))
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(("dmlc-core" ,dmlc-core)))
+ (home-page "https://xgboost.ai/")
+ (synopsis "Gradient boosting (GBDT, GBRT or GBM) library")
+ (description
+ "XGBoost is an optimized distributed gradient boosting library designed
+to be highly efficient, flexible and portable. It implements machine learning
+algorithms under the Gradient Boosting framework. XGBoost provides a parallel
+tree boosting (also known as GBDT, GBM) that solve many data science problems
+in a fast and accurate way.")
+ (license license:asl2.0)))
+
(define-public python-iml
(package
(name "python-iml")