summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-23 17:28:46 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-23 17:28:46 -0600
commit5e42d19781abe8d7b3ad28548a1ba35ba196486a (patch)
tree72c5d9f81d83ee90888f93b2837a8102fd819e45 /gnu/packages/machine-learning.scm
parentbff3661726501ed8c79fd4cfcc677b3161377730 (diff)
downloadguix-patches-5e42d19781abe8d7b3ad28548a1ba35ba196486a.tar
guix-patches-5e42d19781abe8d7b3ad28548a1ba35ba196486a.tar.gz
gnu: Add python-umap-learn.
* gnu/packages/machine-learning.scm (python-umap-learn): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index d7df30e751..719401d69a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2088,3 +2089,31 @@ number of collective algorithms useful for machine learning applications.
These include a barrier, broadcast, and allreduce.")
(home-page "https://github.com/facebookincubator/gloo")
(license license:bsd-3))))
+
+(define-public python-umap-learn
+ (package
+ (name "python-umap-learn")
+ (version "0.3.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "umap-learn" version))
+ (sha256
+ (base32
+ "02ada2yy6km6zgk2836kg1c97yrcpalvan34p8c57446finnpki1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-numba" ,python-numba)
+ ("python-numpy" ,python-numpy)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-scipy" ,python-scipy)))
+ (home-page "https://github.com/lmcinnes/umap")
+ (synopsis
+ "Uniform Manifold Approximation and Projection")
+ (description
+ "Uniform Manifold Approximation and Projection is a dimension reduction
+technique that can be used for visualisation similarly to t-SNE, but also for
+general non-linear dimension reduction.")
+ (license license:bsd-3)))