summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-05-09 10:01:40 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-05-29 18:20:37 -0400
commit3a354e104afc4313a4a59ab9ecf6c9d38f3c629a (patch)
treeb524a326513e526984c86ab8421758e97e8fa425 /gnu/packages/machine-learning.scm
parentde658cc2f851203c7164a0d275df34cdcd161292 (diff)
downloadguix-patches-3a354e104afc4313a4a59ab9ecf6c9d38f3c629a.tar
guix-patches-3a354e104afc4313a4a59ab9ecf6c9d38f3c629a.tar.gz
gnu: Add rxcpp.
* gnu/packages/machine-learning.scm (rxcpp): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index f0d35484ea..6536d861e6 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2018 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -501,6 +502,47 @@ tools. This enables both rapid prototyping of data pipelines and extensibility
in terms of new algorithms.")
(license license:gpl3+)))
+(define-public rxcpp
+ (package
+ (name "rxcpp")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ReactiveX/RxCpp/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y2isr8dy2n1yjr9c5570kpc9lvdlch6jv0jvw000amwn5d3krsh"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-werror
+ (lambda _
+ (substitute* (find-files ".")
+ (("-Werror") ""))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "ctest"))))))
+ (native-inputs
+ `(("catch" ,catch-framework)))
+ (home-page "http://reactivex.io/")
+ (synopsis "Reactive Extensions for C++")
+ (description
+ "The Reactive Extensions for C++ (RxCpp) is a library of algorithms for
+values-distributed-in-time. ReactiveX is a library for composing asynchronous
+and event-based programs by using observable sequences.
+
+It extends the observer pattern to support sequences of data and/or events and
+adds operators that allow you to compose sequences together declaratively while
+abstracting away concerns about things like low-level threading,
+synchronization, thread-safety, concurrent data structures, and non-blocking
+I/O.")
+ (license license:asl2.0)))
+
(define-public r-adaptivesparsity
(package
(name "r-adaptivesparsity")