summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-06-12 10:01:16 +0000
committerLudovic Courtès <ludo@gnu.org>2018-06-14 23:34:59 +0200
commit112c2c010b2e84691302bdc174d9a4825dc6ca24 (patch)
treee689559d31880d07e33365bd51fd235289300703 /gnu/packages/machine-learning.scm
parentbaed923682802b7281bd68274f080d2bb55d3eff (diff)
downloadguix-patches-112c2c010b2e84691302bdc174d9a4825dc6ca24.tar
guix-patches-112c2c010b2e84691302bdc174d9a4825dc6ca24.tar.gz
gnu: Add lightgbm.
* gnu/packages/machine-learning.scm (lightgbm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 15e4d45749..cda5c1e2c8 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages mpi)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -786,3 +787,49 @@ main intended application of Autograd is gradient-based optimization.")
(define-public python2-autograd
(package-with-python2 python-autograd))
+
+(define-public lightgbm
+ (package
+ (name "lightgbm")
+ (version "2.0.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Microsoft/LightGBM/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "132zf0yk0545mg72hyzxm102g3hpb6ixx9hnf8zd2k55gas6cjj1"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-nose" ,python-nose)))
+ (inputs
+ `(("openmpi" ,openmpi)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)))
+ (arguments
+ `(#:configure-flags
+ '("-DUSE_MPI=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion ,(string-append "../LightGBM-" version)
+ (invoke "pytest" "tests/c_api_test/test_.py")))))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/Microsoft/LightGBM")
+ (synopsis "Gradient boosting framework based on decision tree algorithms")
+ (description "LightGBM is a gradient boosting framework that uses tree
+based learning algorithms. It is designed to be distributed and efficient with
+the following advantages:
+
+@itemize
+@item Faster training speed and higher efficiency
+@item Lower memory usage
+@item Better accuracy
+@item Parallel and GPU learning supported (not enabled in this package)
+@item Capable of handling large-scale data
+@end itemize\n")
+ (license license:expat)))