summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-28 22:55:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-02 21:47:28 -0400
commit01f3f0e928bd614b8b2c9aea5b93bdc6a4b07963 (patch)
tree43267da9267ad3f5446786fc85843e3f9c08ac4e /gnu/packages/machine-learning.scm
parent9496fa0724021220c2818ed724cd053e54c4e0f0 (diff)
downloadguix-patches-01f3f0e928bd614b8b2c9aea5b93bdc6a4b07963.tar
guix-patches-01f3f0e928bd614b8b2c9aea5b93bdc6a4b07963.tar.gz
gnu: ocaml-mcl: Fix build.
It was failing on a /bin/sh occurrence patched twice in the configure script: sh: ./configure:/gnu/store/...-bash-minimal-5.0.16/gnu/store/...-bash-minimal-5.0.1:bad interpreter: No such file or directory * gnu/packages/machine-learning.scm (ocaml-mcl)[phases]{patch-paths}: Do not patch the configure script.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm2
1 files changed, 0 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 89345fa5fd..c82a06f3bb 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -330,8 +330,6 @@ networks) based on simulation of (stochastic) flow in graphs.")
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
(lambda _
- (substitute* "configure"
- (("/bin/sh") (which "sh")))
(substitute* "setup.ml"
(("LDFLAGS=-fPIC")
(string-append "LDFLAGS=-fPIC\"; \"SHELL=" (which "sh")))