summaryrefslogtreecommitdiff
path: root/gnu/packages/m4.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 18:23:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 19:29:16 +0100
commit05d86d70d9bc19d08716460f40976b74b97b6031 (patch)
tree6b12c1af18fbbc2c6cfec2fec5f7b6b3f632641e /gnu/packages/m4.scm
parent5170bbd5bcbcdacff517641ac19b3ba8c2205c5e (diff)
downloadguix-patches-05d86d70d9bc19d08716460f40976b74b97b6031.tar
guix-patches-05d86d70d9bc19d08716460f40976b74b97b6031.tar.gz
gnu: m4: Update phase style.
* gnu/packages/m4.scm (m4)[arguments]: Use MODIFY-PHASES syntax and end phase with #t.
Diffstat (limited to 'gnu/packages/m4.scm')
-rw-r--r--gnu/packages/m4.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/m4.scm b/gnu/packages/m4.scm
index 32e7c2ae42..b223ce91d1 100644
--- a/gnu/packages/m4.scm
+++ b/gnu/packages/m4.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,18 +41,19 @@
;; proceeds and fails, unsurprisingly.
#:tests? ,(not (%current-target-system))
- #:phases (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Fix references to /bin/sh.
- (let ((bash (assoc-ref inputs "bash")))
- (for-each patch-shebang
- (find-files "tests" "\\.sh$"))
- (substitute* (find-files "tests"
- "posix_spawn")
- (("/bin/sh")
- (format #f "~a/bin/sh" bash)))))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Fix references to /bin/sh.
+ (let ((bash (assoc-ref inputs "bash")))
+ (for-each patch-shebang
+ (find-files "tests" "\\.sh$"))
+ (substitute* (find-files "tests"
+ "posix_spawn")
+ (("/bin/sh")
+ (format #f "~a/bin/sh" bash)))
+ #t))))))
(synopsis "Macro processor")
(description
"GNU M4 is an implementation of the M4 macro language, which features