summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 10:55:46 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commitfab3484657e4728496d39bb9d3518ea19412e1cf (patch)
treea0dfa0b284e2e1732c5d9fe8175edf3d95991441 /gnu/packages/lxqt.scm
parent96b4977a1924ca648a3cceb15443539104d294f1 (diff)
downloadguix-patches-fab3484657e4728496d39bb9d3518ea19412e1cf.tar
guix-patches-fab3484657e4728496d39bb9d3518ea19412e1cf.tar.gz
gnu: Add lxqt-globalkeys.
* gnu/packages/lxqt.scm (lxqt-globalkeys): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index b45d21c87b..a270aff7a9 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -197,6 +197,50 @@ itself as well as other components maintained by the LXQt project.")
(home-page "https://lxqt.org")
(license lgpl2.1+)))
+(define-public lxqt-globalkeys
+ (package
+ (name "lxqt-globalkeys")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1gyvcjbhi7zpvgz1sf773dv9gc35hx5fz023njp9r4vl0dpcavgd"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)
+ ("lxqt-build-tools" ,lxqt-build-tools)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("autostart/CMakeLists.txt"
+ "xdg/CMakeLists.txt")
+ (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ #t)))))
+ (home-page "https://lxqt.org/")
+ (synopsis "Daemon used to register global keyboard shortcuts")
+ (description "lxqt-globalkeys is providing tools to set global keyboard
+shortcuts in LXQt sessions, that is shortcuts which apply to the LXQt session
+as a whole and are not limited to distinct applications.")
+ (license lgpl2.1+)))
+
(define-public lxqt-session
(package
(name "lxqt-session")