summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:30:03 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:53 +0800
commite8b4c9af4b517c0d34d18f620aec7f59032ede20 (patch)
treefe94339ad7bdd9261b326f409d53b2ef1029d52a /gnu/packages/lxqt.scm
parent90d5792eeaae0b17c0a89cda1a3aed4dd25050f9 (diff)
downloadguix-patches-e8b4c9af4b517c0d34d18f620aec7f59032ede20.tar
guix-patches-e8b4c9af4b517c0d34d18f620aec7f59032ede20.tar.gz
gnu: lxqt-globalkeys: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-globalkeys): Update to 1.1.0. [arguments]: Remove phases.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 56284bc638..2d249f4ed1 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -423,7 +423,7 @@ configuration of both LXQt and the underlying operating system.")
(define-public lxqt-globalkeys
(package
(name "lxqt-globalkeys")
- (version "0.17.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -431,7 +431,7 @@ configuration of both LXQt and the underlying operating system.")
"releases/download/" version "/"
"lxqt-globalkeys-" version ".tar.xz"))
(sha256
- (base32 "0pnyqiqhaawrnyvw3ljp850d911abaalnl4rgvl2xyzybvlhki4h"))))
+ (base32 "0bbw85aa59w0qnvkdggm3hbacps6yfcvcrs32d34mvvhc7d6g04l"))))
(build-system cmake-build-system)
(inputs
(list kwindowsystem
@@ -442,24 +442,7 @@ configuration of both LXQt and the underlying operating system.")
qtx11extras))
(native-inputs
(list pkg-config qttools-5 lxqt-build-tools))
- (arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* '("autostart/CMakeLists.txt"
- "xdg/CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
- "DESTINATION \"etc/xdg"))
- #t))
- (add-after 'unpack 'patch-translations-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "config/CMakeLists.txt"
- (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
- (string-append (assoc-ref outputs "out")
- "/share/lxqt/translations")))
- #t)))))
+ (arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "Daemon used to register global keyboard shortcuts")
(description "lxqt-globalkeys is providing tools to set global keyboard