summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 14:10:48 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-25 21:12:19 +0800
commita98000a4625a075f3c47898b9c0fdf570f7c0024 (patch)
tree2bad88f36cde65c85be2ea0c0c80218df30f521e /gnu/packages/lxqt.scm
parentf2b48558dfe033708e02667e24e08cd5c0861aa3 (diff)
downloadguix-patches-a98000a4625a075f3c47898b9c0fdf570f7c0024.tar
guix-patches-a98000a4625a075f3c47898b9c0fdf570f7c0024.tar.gz
gnu: Add lxqt-notificationd.
* gnu/packages/lxqt.scm (lxqt-notificationd): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 7f2d251a76..31b7a5ab35 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -429,6 +429,47 @@ shortcuts in LXQt sessions, that is shortcuts which apply to the LXQt session
as a whole and are not limited to distinct applications.")
(license license:lgpl2.1+)))
+(define-public lxqt-notificationd
+ (package
+ (name "lxqt-notificationd")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1l0hdbvghyhqgvy4pih7rvz26bc6yc8a3l1bdj11hnkw62h1i7d6"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f ; no test target
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("autostart/CMakeLists.txt")
+ (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+ #t)))))
+ (home-page "https://lxqt.org/")
+ (synopsis "The LXQt notification daemon")
+ (description "lxqt-notificationd is LXQt's implementation of a daemon
+according to the Desktop Notifications Specification.")
+ (license license:lgpl2.1+)))
+
(define-public lxqt-panel
(package
(name "lxqt-panel")