summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 22:34:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 22:35:26 +0100
commit4a7f132240266fa75bd99e5d4198667bed47bfb7 (patch)
treee2cf73ce2a68a79654c7a63032acc65f8db0b4d0 /gnu/packages/lxqt.scm
parent7b25f8a45cfc89383ba1196f7388110afe12bf40 (diff)
downloadguix-patches-4a7f132240266fa75bd99e5d4198667bed47bfb7.tar
guix-patches-4a7f132240266fa75bd99e5d4198667bed47bfb7.tar.gz
gnu: libqtxdg: Update to 3.4.0.
* gnu/packages/lxqt.scm (libqtxdg): Update to 3.4.0. [propagated-inputs]: Add glib. [inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 8d5d3522ec..87b21fa9e4 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -158,7 +158,7 @@ itself as well as other components maintained by the LXQt project.")
(define-public libqtxdg
(package
(name "libqtxdg")
- (version "3.3.1")
+ (version "3.4.0")
(source
(origin
(method url-fetch)
@@ -166,7 +166,7 @@ itself as well as other components maintained by the LXQt project.")
"https://github.com/lxqt/libqtxdg/releases/download/"
version "/libqtxdg-" version ".tar.xz"))
(sha256
- (base32 "1mnnq8vbf5xjlrzajzfkay0yzzxri0zz0xi8x8rmxpw38xmglq8h"))))
+ (base32 "0vmn59653dmy79mnbnibhdq9jmh11091zkfx0y0qh58rj2xvpdbv"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -181,10 +181,12 @@ itself as well as other components maintained by the LXQt project.")
#t)))))
(propagated-inputs
;; required by Qt5XdgIconLoader.pc
- `(("qtbase" ,qtbase)
+ `(("glib" ,glib)
+ ("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
(native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)))
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("pkg-config" ,pkg-config)))
(home-page "https://github.com/lxqt/libqtxdg")
(synopsis "Qt implementation of freedesktop.org xdg specifications")
(description "Libqtxdg implements the freedesktop.org xdg specifications