summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 11:53:30 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commit34e08de321366844140d37879c5e80a45ecbb23c (patch)
tree893fab2a2773d0e0af8d06d8b0d3d661616bbcea /gnu/packages/lxqt.scm
parent2bdab26f06d5b1767400ad7688e4b37e1b628a0c (diff)
downloadguix-patches-34e08de321366844140d37879c5e80a45ecbb23c.tar
guix-patches-34e08de321366844140d37879c5e80a45ecbb23c.tar.gz
gnu: Add lxqt-admin.
* gnu/packages/lxqt.scm (lxqt-admin): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 467240af09..6965847bb2 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -270,6 +270,47 @@ and memory usage or network traffic.")
LXQt and the system it's running on.")
(license lgpl2.1+)))
+(define-public lxqt-admin
+ (package
+ (name "lxqt-admin")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0qvpv668ja83ydbdrlal1596xhag3xlkbd6qlh9xwdpb7nysvns1"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("liblxqt" ,liblxqt)
+ ("libqtxdg" ,libqtxdg)
+ ("polkit-qt" ,polkit-qt)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "lxqt-admin-user/CMakeLists.txt"
+ (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+ #t)))))
+ (home-page "https://lxqt.org")
+ (synopsis "LXQt system administration tool")
+ (description "lxqt-admin is providing two GUI tools to adjust settings of
+the operating system LXQt is running on.")
+ (license lgpl2.1+)))
+
(define-public lxqt-build-tools
(package
(name "lxqt-build-tools")