summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-23 16:10:15 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-28 22:15:45 +0200
commitf3b3af37d4ab2ad621fee64469dff4f49bec805d (patch)
tree9024d4f1b4b032007d4926922ba973f0961bddb6 /gnu/packages/lxde.scm
parent169274d5c58cf3ce385d8ce0b64e2ac57a68906c (diff)
downloadguix-patches-f3b3af37d4ab2ad621fee64469dff4f49bec805d.tar
guix-patches-f3b3af37d4ab2ad621fee64469dff4f49bec805d.tar.gz
gnu: Add lxinput.
* gnu/packages/lxde.scm (lxinput): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 6862784f4e..1a3cfab0bd 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -287,4 +287,29 @@ menu spec-compliant desktop menus for LXDE.")
(home-page "http://lxde.org")
(license license:gpl2+)))
+(define-public lxinput
+ (package
+ (name "lxinput")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.sourceforge.net/lxde/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "123f3yn4rp1w5b3n5aj3ad9snkxab29qkrs7bcvf5bx4cn57g3sf"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gtk+-2" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (synopsis "Tool for mouse and keyboard configuration in LXDE")
+ (description
+ "Lxinput provides a small program to configure keyboard and mouse
+in LXDE.")
+ (home-page "http://lxde.org")
+ (license license:gpl2+)))
+
;;; lxde.scm ends here