summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-23 18:55:49 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-01-23 21:19:17 +0100
commitdc29cc7710a5909be35ae7b0d7ce4443f6ab4b3d (patch)
treeee0f1c24da01d81ccb0f31ceca0d5db14885c92c /gnu/packages/lxde.scm
parent34ab353849714adbb3e2b3bcb9afcb68b81ff69f (diff)
downloadguix-patches-dc29cc7710a5909be35ae7b0d7ce4443f6ab4b3d.tar
guix-patches-dc29cc7710a5909be35ae7b0d7ce4443f6ab4b3d.tar.gz
gnu: lxterminal: Update to 0.3.0.
* gnu/packages/lxde.scm (lxterminal): Update to 0.3.0. [arguments]: Disable tests. [source]: Update to use new '.tar.xz' tarball. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index dedaaee27b..a99e8b0e60 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -143,16 +144,20 @@ toolkit. It allows users to monitor and control of running processes.")
(define-public lxterminal
(package
(name "lxterminal")
- (version "0.2.0")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/lxde/LXTerminal"
"%20%28terminal%20emulator%29/LXTerminal%20"
- version "/" name "-" version ".tar.gz"))
+ version "/" name "-" version ".tar.xz"))
(sha256
(base32
- "1brb506vmnncih8nyvlrckrrn6msbsvz2vwbm7bsqwigcnchwjqp"))))
+ "1yf76s15zvfw0h42b0ay1slpq47khgjmcry8ki2z812zar9lchia"))))
(build-system gnu-build-system)
+ (arguments
+ `(;; Tests for "po" fail with "No rule to make target '../src/encoding.c'
+ ;; needed by 'lxterminal.pot'. Stop."
+ #:tests? #f))
(inputs `(("gtk+" ,gtk+-2)
("vte" ,vte/gtk+-2)))
(native-inputs `(("intltool" ,intltool)