summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-27 00:34:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-27 02:56:43 +0200
commitca2158bb3a0f5de3108a4f81e6733a5309e9af1d (patch)
treeb9d9e99a16956148a734023eddccdf1a90a24cc6 /gnu/packages/lxde.scm
parentd5db813b382e941710771ab937bba45d62527691 (diff)
downloadguix-patches-ca2158bb3a0f5de3108a4f81e6733a5309e9af1d.tar
guix-patches-ca2158bb3a0f5de3108a4f81e6733a5309e9af1d.tar.gz
gnu: pcmanfm: Update to 1.3.0.
* gnu/packages/lxde.scm (pcmanfm): Update to 1.3.0. [source]: Remove patch. * gnu/packages/patches/pcmanfm-CVE-2017-8934.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 97ab8720d6..67e66f8f6b 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -205,26 +205,25 @@ speed up the access to freedesktop.org defined application menus.")
(define-public pcmanfm
(package
(name "pcmanfm")
- (version "1.2.5")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/"
"PCManFM%20%2B%20Libfm%20%28tarball%20release"
"%29/PCManFM/" name "-" version ".tar.xz"))
- (patches (search-patches "pcmanfm-CVE-2017-8934.patch"))
(sha256
(base32
- "0rxdh0dfzc84l85c54blq42gczygq8adhr3l9hqzy1dp530cm1hc"))))
+ "1ywgfyklms5hqkapsbjps4kyx20ac0d1qk16ww74yagkyfdkwsas"))))
(build-system gnu-build-system)
(inputs `(("gtk+" ,gtk+-2)
- ("gvfs" ,gvfs) ;for trash and mount support
+ ("gvfs" ,gvfs) ; for trash and mount support
("libfm" ,libfm)
("libx11" ,libx11)))
(native-inputs `(("intltool" ,intltool)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("lxmenu-data" ,lxmenu-data))) ;for "Open With..." application list
+ `(("lxmenu-data" ,lxmenu-data))) ; for "Open With..." application list
(synopsis "LXDE file manager")
(description "PCMan is a lightweight GTK+ based file manager, compliant
with freedesktop.org standard.")