summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 10:16:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 10:16:43 +0100
commita49b5322c56cd5b7778a8c8ffea95f9c28339cc7 (patch)
tree815c5af7da5a41052daa4a592dc9ed008d5766dd /gnu/packages/lxde.scm
parentf1f1cebdd3f2ca18d77e8f8a1f5760a65e7137fb (diff)
downloadguix-patches-a49b5322c56cd5b7778a8c8ffea95f9c28339cc7.tar
guix-patches-a49b5322c56cd5b7778a8c8ffea95f9c28339cc7.tar.gz
gnu: lxsession: Remove custom bootstrap phase.
* gnu/packages/lxde.scm (lxsession)[arguments]: Remove autoreconf phase and end rm-stamp phase with #T.
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index c45beb8bbb..1f32ec3bb1 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ison111 <ison111@protonmail.com>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -419,10 +420,10 @@ in LXDE.")
(modify-phases %standard-phases
(add-after 'unpack 'rm-stamp
(lambda _
- (for-each delete-file (find-files "." "\\.stamp$"))))
- (add-after 'rm-stamp 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (for-each delete-file (find-files "." "\\.stamp$"))
+ ;; Force regeneration of configure script.
+ (delete-file "configure")
+ #t)))))
(inputs
`(("gtk+-2" ,gtk+-2)
("polkit" ,polkit)))