summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-23 17:44:50 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-28 22:15:45 +0200
commit812c1819a0ca740d2ab165d691806def2a2d119f (patch)
tree3dd22a9e46156045cbd0a4154c0c90be75b822c0 /gnu/packages/lxde.scm
parent50042505db06b7b8a8708702d0ce6621d8a98f07 (diff)
downloadguix-patches-812c1819a0ca740d2ab165d691806def2a2d119f.tar
guix-patches-812c1819a0ca740d2ab165d691806def2a2d119f.tar.gz
gnu: Add lxde.
* gnu/packages/lxde.scm (lxde): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 08fafa2372..0844263713 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,12 +27,14 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages openbox)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -409,4 +411,41 @@ in LXDE.")
(home-page "http://lxde.org")
(license license:gpl2+)))
+(define-public lxde
+ (package
+ (name "lxde")
+ (version (package-version lxde-common))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments '(#:builder (mkdir %output)))
+ (propagated-inputs
+ ;; TODO:
+ ;; lxshortcut, lxsession-edit, gpicview, leafpad,
+ ;; lxappearance-obconf
+ `(("menu-cache" ,menu-cache)
+ ("lxappearance" ,lxappearance)
+ ("lxde-icon-theme" ,lxde-icon-theme)
+ ("lxde-common" ,lxde-common)
+ ("lxmenu-data" ,lxmenu-data)
+ ("lxpanel" ,lxpanel)
+ ("lxrandr" ,lxrandr)
+ ("lxsession" ,lxsession)
+ ("libfm" ,libfm)
+ ("libfm-extra" ,libfm-extra)
+ ("lxtask" ,lxtask)
+ ("lxterminal" ,lxterminal)
+ ("pcmanfm" ,pcmanfm)
+ ("openbox" ,openbox)
+ ("obconf" ,obconf)))
+ (synopsis "Lightweight X11 Desktop Environment")
+ (description
+ "LXDE, which stands for Lightweight X11 Desktop Environment, is a
+desktop environment which is lightweight and fast. It is designed to be
+user friendly and slim, while keeping the resource usage low. LXDE uses
+less RAM and less CPU while being a feature rich desktop environment. Unlike
+other tightly integrated desktops LXDE strives to be modular, so each
+component can be used independently with few dependencies.")
+ (home-page "https://lxde.org")
+ (license license:gpl2+))) ; And others.
+
;;; lxde.scm ends here