summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-07-15 23:10:37 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-07-22 00:15:16 +0200
commit729b44e3ae42e44cdaba978966dcdb6bc1f1c76e (patch)
tree425a53cb8365fbcec7982d078396a21fa06fb67a /gnu/packages/lxde.scm
parent6f92ad5a510fd4f75b4c8b85c42e499a12321d12 (diff)
downloadguix-patches-729b44e3ae42e44cdaba978966dcdb6bc1f1c76e.tar
guix-patches-729b44e3ae42e44cdaba978966dcdb6bc1f1c76e.tar.gz
gnu: Add lxrandr.
* gnu/packages/lxde.scm (lxrandr): New variable.
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 7b67ddc66f..fe71a17406 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -89,6 +89,32 @@ able to change themes, icons, and fonts used by GTK+ applications.")
(home-page "http://lxde.org")
(license license:gpl2+)))
+(define-public lxrandr
+ (package
+ (name "lxrandr")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/project/lxde/LXRandR"
+ "%20%28monitor%20config%20tool%29/LXRandR%20"
+ (version-major+minor version) ".x/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0xkbqv66hisbxkvnf7y5kwqbhrq26f49wd7w6ylhnjlccpnylg8q"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+-2)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "LXDE monitor configuration tool")
+ (description "LXRandR is a very basic monitor configuration tool. It
+relies on the X11 resize-and-rotate (RandR) extension but doesn't aim to be a
+full frontend of it. LXRandR only gives you some easy and quick options which
+are intuitive. It's suitable for laptop users who frequently uses projectors
+or external monitor.")
+ (home-page "http://lxde.org")
+ (license license:gpl2+)))
+
(define-public lxtask
(package
(name "lxtask")