summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:47:33 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:50:58 +0200
commit3e616cae7ad26ffb9d8395cbf60cbedc8716def1 (patch)
treebecaa9b20e46c4c2f8b8c31de810f6a7808f5bda /gnu/packages/lxde.scm
parent24a472d9d58f6236497f197326f4ba194b918b23 (diff)
downloadguix-patches-3e616cae7ad26ffb9d8395cbf60cbedc8716def1.tar
guix-patches-3e616cae7ad26ffb9d8395cbf60cbedc8716def1.tar.gz
gnu: menu-cache: Fix build.
* gnu/packages/lxde.scm (menu-cache)[arguments]: Pass '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 7f483cfe1f..34cee44730 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -226,6 +227,8 @@ performance, all instances of the terminal are sharing a single process.")
(inputs `(("glib" ,glib)
("libfm" ,libfm-extra)))
(native-inputs `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags '("CFLAGS=-fcommon")))
(synopsis "LXDE implementation of the freedesktop menu's cache")
(description "Menu-cache is a library creating and utilizing caches to
speed up the access to freedesktop.org defined application menus.")