summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-01-24 15:40:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-31 20:39:39 +0100
commitd9ed1779b88cddbb1de0be0fc8024a1b7c3dbad2 (patch)
tree2f75ded01409913266d4c63441b9f02bd8ff2c4f /gnu/packages/lua.scm
parentcf9a788d93166da262cdeb1a08ec59b481e0eb2c (diff)
downloadguix-patches-d9ed1779b88cddbb1de0be0fc8024a1b7c3dbad2.tar
guix-patches-d9ed1779b88cddbb1de0be0fc8024a1b7c3dbad2.tar.gz
gnu: Add lua5.2-lpeg.
* gnu/packages/lua.scm (lua5.2-lpeg): New variable.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 28f66a5960..8bb9a401a6 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -402,6 +402,30 @@ Grammars (PEGs).")
(home-page "http://www.inf.puc-rio.br/~roberto/lpeg")
(license license:expat)))
+(define-public lua5.2-lpeg
+ (package (inherit lua-lpeg)
+ (name "lua5.2-lpeg")
+ ;; XXX: The arguments field is almost an exact copy of the field in
+ ;; "lua-lpeg", except for the version string, which was derived from "lua"
+ ;; and now is taken from "lua-5.2". See this discussion for context:
+ ;; http://lists.gnu.org/archive/html/guix-devel/2017-01/msg02048.html
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ ;; `make install` isn't available, so we have to do it manually
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (lua-version ,(version-major+minor (package-version lua-5.2))))
+ (install-file "lpeg.so"
+ (string-append out "/lib/lua/" lua-version))
+ (install-file "re.lua"
+ (string-append out "/share/lua/" lua-version))
+ #t))))
+ #:test-target "test"))
+ (inputs `(("lua", lua-5.2)))))
+
;; Lua 5.3 is not supported.
(define-public lua5.2-bitop
(package