summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authordoncatnip <gnopap@gmail.com>2016-09-01 23:08:28 +0200
committerLeo Famulari <leo@famulari.name>2016-09-20 14:58:29 -0400
commitc0d47cadea6fc5f968e982b2373ce1347bcc6988 (patch)
tree500df46319d9985746ebdfcdfcf1f797f7653747 /gnu/packages/lua.scm
parente6d58734b6037640d7b1a04fe3a1c2fa6cbc203f (diff)
downloadguix-patches-c0d47cadea6fc5f968e982b2373ce1347bcc6988.tar
guix-patches-c0d47cadea6fc5f968e982b2373ce1347bcc6988.tar.gz
gnu: lua: Use MYCFLAGS instead of CFLAGS.
* gnu/packages/lua.scm (lua)[arguments]: Use MYCFLAGS instead of CFLAGS and remove conflicting -DLUA_USE_POSIX since -DLUA_USE_LINUX is passed implicitly for build target "linux". Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 274330fd3d..f2e9da20fd 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -51,7 +51,7 @@
(srfi srfi-1))
#:test-target "test"
#:make-flags
- '("CFLAGS=-fPIC -DLUA_DL_DLOPEN -DLUA_USE_POSIX"
+ '("MYCFLAGS=-fPIC -DLUA_DL_DLOPEN"
"linux")
#:phases
(modify-phases %standard-phases