summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>2021-02-23 17:25:07 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-24 16:47:44 +0100
commitb35bbb26a25b562877808bf675b275a93ffb3794 (patch)
treef0b32a752c6dc52759334119732d34a95cc25d5f /gnu/packages/lua.scm
parentb5586c666e13988ce7ec983907ffb06a564f1d4f (diff)
downloadguix-patches-b35bbb26a25b562877808bf675b275a93ffb3794.tar
guix-patches-b35bbb26a25b562877808bf675b275a93ffb3794.tar.gz
gnu: Add luajit-lua52-openresty.
* gnu/packages/lua.scm (luajit-lua52-openresty): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index b029400cb2..81846afe82 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -157,6 +157,38 @@ language. It may be embedded or used as a general-purpose, stand-alone
language.")
(license license:x11)))
+(define-public luajit-lua52-openresty
+ (package
+ (inherit luajit)
+ (name "luajit-lua52-openresty")
+ (version "2.1-20201229")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openresty/luajit2.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "07haj27kbpbnkv836c2nd36h2xislrmri52w0zbpxvl68xk6g96p"))))
+ (arguments
+ `(#:tests? #f ;no test
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-after 'unpack 'enable-lua52-compat
+ (lambda _
+ (substitute* "src/Makefile"
+ (("#(XCFLAGS\\+= -DLUAJIT_ENABLE_LUA52COMPAT)" _ flag) flag))
+ #t)))))
+ (home-page "https://github.com/openresty/luajit2")
+ (synopsis "OpenResty's Branch of LuaJIT 2")
+ (description
+ "This is the official OpenResty branch of LuaJIT. It is not to be
+considered a fork, since changes are regularly synchronized from the upstream
+LuaJIT project. This package also enables the Lua 5.2 compat mode needed by
+some projects.")))
+
(define (make-lua-expat name lua)
(package
(name name)