summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>2021-06-18 20:20:01 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-22 10:54:16 +0200
commit9ba41ea8231c44cf4d7312891b8d9add277e5d89 (patch)
treeb9bd7ef90603b93b3e61c28d3609c729cb0959e2 /gnu/packages/lua.scm
parent17972082ccb05cce550bc095d23bd6dcaf3ec5a7 (diff)
downloadguix-patches-9ba41ea8231c44cf4d7312891b8d9add277e5d89.tar
guix-patches-9ba41ea8231c44cf4d7312891b8d9add277e5d89.tar.gz
gnu: emilua: Update to 0.3.2.
* gnu/packages/lua.scm (emilua): Update to 0.3.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 54d2ba400d..0ecc91294f 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1108,23 +1108,20 @@ shell command executions.")
(define-public emilua
(package
(name "emilua")
- (version "0.3.0")
+ (version "0.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/emilua/emilua.git")
(commit (string-append "v" version))
- ;; Current version requires bundled CLI11, but at some future
- ;; release the one found in the system could be used
- ;; instead. Current version also requires Trial.Protocol and
- ;; the HTTP lib developed as part of GSoC 2014 for Boost, but
- ;; these are dependencies unlikely to be "unbundled" in future
- ;; releases.
+ ;; Current version requires Trial.Protocol and the HTTP lib
+ ;; developed as part of GSoC 2014 for Boost, and these are
+ ;; dependencies unlikely to be "unbundled" in future releases.
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "124fj73722c03znwdyqp1i0jygwv3s11f6s1j9rzym513qrf7fnd"))))
+ "1999bgrh52124a5g4qizav3x257ff2brjr855srpm1jv1nxzbygv"))))
(build-system meson-build-system)
(arguments
`(#:meson ,meson-0.55