summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-16 15:12:46 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-16 15:12:46 +0200
commit90f80bf21cce30b92c48958f5a5dcb12942b69a4 (patch)
tree40c0754f2be424ec8bb39f34475b1e43e7bccb60 /gnu/packages/lua.scm
parent395bea2a53ed7398e52a0a85370a554501af5678 (diff)
downloadguix-patches-90f80bf21cce30b92c48958f5a5dcb12942b69a4.tar
guix-patches-90f80bf21cce30b92c48958f5a5dcb12942b69a4.tar.gz
gnu: lua: Compile with -fPIC.
* gnu/packages/lua.scm (lua): Add -fPIC to CFLAGS and LDFLAGS.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 991cfc6e67..f2a603bc91 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,7 +46,7 @@
#:test-target "test"
#:phases (alist-replace
'build
- (lambda _ (zero? (system* "make" "linux"))) ; XXX: Other OS.
+ (lambda _ (zero? (system* "make" "CFLAGS=-fPIC" "linux")))
(alist-replace
'install
(lambda* (#:key outputs #:allow-other-keys)