summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-11 17:27:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-14 23:41:26 +0300
commit89c4122ec9b816e5d6902c3b17e912543fd21033 (patch)
tree0a8f5edec1140523c4c9b7d0cbdba3d639b785a8 /gnu/packages/lua.scm
parent0100fd06c947225b44ccc72069886cc8be10f6bc (diff)
downloadguix-patches-89c4122ec9b816e5d6902c3b17e912543fd21033.tar
guix-patches-89c4122ec9b816e5d6902c3b17e912543fd21033.tar.gz
gnu: Add lua-resty-shell.
* gnu/packages/lua.scm (lua-resty-shell): New variable.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index d30692d2df..2f21d85d0b 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1024,3 +1024,38 @@ signals to Linux processes.")
(synopsis "Lua table recycling pools for LuaJIT")
(description "This package provides Lua table recycling pools for LuaJIT.")
(license license:bsd-2)))
+
+(define-public lua-resty-shell
+ (package
+ (name "lua-resty-shell")
+ (version "0.03")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openresty/lua-resty-shell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s6g04ip4hr97r2pd8ry3alq063604s9a3l0hn9nsidh81ps4dp7"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((luajit-major+minor ,(version-major+minor (package-version lua)))
+ (package-lua-resty (lambda (input output)
+ (mkdir-p (string-append output "/lib/lua/" luajit-major+minor))
+ (copy-recursively (string-append input "/lib/resty")
+ (string-append output "/lib/lua/" luajit-major+minor "/resty"))
+ (symlink (string-append output "/lib/lua/" luajit-major+minor "/resty")
+ (string-append output "/lib/resty")))))
+ (package-lua-resty (assoc-ref %build-inputs "source")
+ (assoc-ref %outputs "out")))
+ #t)))
+ (home-page "https://github.com/openresty/lua-resty-shell")
+ (synopsis "Lua module for nonblocking system shell command executions")
+ (description "This package provides Lua module for nonblocking system
+shell command executions.")
+ (license license:bsd-3)))