summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-11 17:26:32 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-14 23:41:25 +0300
commit8688fd8fa1970c155f520dcc95afccecd3e10a2d (patch)
tree500438cd9ee7a89de75384d2b52cf6b031494651 /gnu/packages/lua.scm
parent1263bd0dbf55f340e5292bcee00dd1f3d4eb6ef1 (diff)
downloadguix-patches-8688fd8fa1970c155f520dcc95afccecd3e10a2d.tar
guix-patches-8688fd8fa1970c155f520dcc95afccecd3e10a2d.tar.gz
gnu: Add lua-resty-signal.
* gnu/packages/lua.scm (lua-resty-signal): New variable.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 59d449dfe5..60f88c1536 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -952,3 +952,43 @@ on numbers.")
(description
"This package provides Lua LRU cache based on the LuaJIT FFI.")
(license license:bsd-2)))
+
+(define-public lua-resty-signal
+ (package
+ (name "lua-resty-signal")
+ (version "0.02")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openresty/lua-resty-signal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13y1pqn45y49mhqwywasfdsid46d0c33yi6mrnracbnmvyxz1cif"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;TODO: Run the test suite.
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'install 'install-lua
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (use-modules (guix build utils))
+ (let* ((luajit-major+minor ,(version-major+minor (package-version lua)))
+ (package-lua-resty (lambda (input output)
+ (mkdir-p (string-append output "/lib/lua/" luajit-major+minor))
+ (copy-recursively (string-append input "/lib/resty")
+ (string-append output "/lib/lua/" luajit-major+minor "/resty"))
+ (symlink (string-append output "/lib/lua/" luajit-major+minor "/resty")
+ (string-append output "/lib/resty")))))
+ (package-lua-resty (assoc-ref inputs "source")
+ (assoc-ref outputs "out")))
+ #t)))))
+ (home-page "https://github.com/openresty/lua-resty-signal")
+ (synopsis "Lua library for killing or sending signals to Linux processes")
+ (description "This package provides Lua library for killing or sending
+signals to Linux processes.")
+ (license license:bsd-3)))