summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-03-15 05:41:12 +0100
committercyril <cyril@oldie>2013-03-19 23:27:04 +0100
commit712e6e684cdab33edafa293cf1484b3866b23098 (patch)
tree1c2f51081a862548651baa7da4c1bb05886f5ae2 /gnu/packages/lua.scm
parent84a3e3b7767fbd9336c7ca704fe956e79c20a6bc (diff)
downloadguix-patches-712e6e684cdab33edafa293cf1484b3866b23098.tar
guix-patches-712e6e684cdab33edafa293cf1484b3866b23098.tar.gz
gnu: Add lua.
* gnu/packages/lua.scm: New file. * Makefile.am: add it.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
new file mode 100644
index 0000000000..14fc28ced0
--- /dev/null
+++ b/gnu/packages/lua.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lua)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages readline))
+
+(define-public lua
+ (package
+ (name "lua")
+ (version "5.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.lua.org/ftp/lua-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1rbv2ysq5fdksz7xg07dnrkl8i0gnx855hg4z6b324vng6l4sc34"))))
+ (build-system gnu-build-system)
+ (inputs `(("readline", readline)))
+ (arguments
+ '(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:test-target "test"
+ #:phases (alist-replace
+ 'build
+ (lambda _ (zero? (system* "make" "linux"))) ; XXX: Other OS.
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system
+ (string-append "make install INSTALL_TOP=" out)))))
+ (alist-delete 'configure %standard-phases)))))
+ (home-page "http://www.lua.org/")
+ (synopsis "An embeddable scripting language.")
+ (description
+ "Lua is a powerful, fast, lightweight, embeddable scripting language. Lua
+combines simple procedural syntax with powerful data description constructs
+based on associative arrays and extensible semantics. Lua is dynamically typed,
+runs by interpreting bytecode for a register-based virtual machine, and has
+automatic memory management with incremental garbage collection, making it ideal
+for configuration, scripting, and rapid prototyping.")
+ (license x11)))