summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-31 13:02:59 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-06 16:17:16 +0000
commit6dbf1fec0d56152a9a893045cd508d337349e02a (patch)
treed8a03d29b5b3e0b3b7fa87acccc1a411bb46bf2b /gnu/packages/lua.scm
parentde975de39b48cdf9c72fb81d003f7bc7dd23a744 (diff)
downloadguix-patches-6dbf1fec0d56152a9a893045cd508d337349e02a.tar
guix-patches-6dbf1fec0d56152a9a893045cd508d337349e02a.tar.gz
gnu: lua: Update to 5.3.3.
* gnu/packages/patches/lua52-liblua-so.patch: Rename to ... * gnu/packages/patches/lua-liblua-so.patch: ... this. Add version comment. * gnu/local.mk (dist_patch_DATA): Adjust patch name. * gnu/packages/lua.scm (lua): Update to 5.3.3. [source]: Use https URL. Use new patch name. [home-page]: Use https URL. (lua-5.2): New variable. (lua-5.1)[source]: Use https URL.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 8fdba61e92..fe0ec208aa 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -40,15 +40,15 @@
(define-public lua
(package
(name "lua")
- (version "5.2.4")
+ (version "5.3.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.lua.org/ftp/lua-"
+ (uri (string-append "https://www.lua.org/ftp/lua-"
version ".tar.gz"))
(sha256
- (base32 "0jwznq0l8qg9wh5grwg07b5cy3lzngvl5m2nl1ikp6vqssmf9qmr"))
+ (base32 "18mcfbbmjyp8f2l9yy7n6dzk066nq6man0kpwly4bppphilc04si"))
(patches (search-patches "lua-pkgconfig.patch"
- "lua52-liblua-so.patch"))))
+ "lua-liblua-so.patch"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments
@@ -69,7 +69,7 @@
(string-append "INSTALL_TOP=" out)
(string-append "INSTALL_MAN=" out
"/share/man/man1")))))))))
- (home-page "http://www.lua.org/")
+ (home-page "https://www.lua.org/")
(synopsis "Embeddable scripting language")
(description
"Lua is a powerful, fast, lightweight, embeddable scripting language. Lua
@@ -80,12 +80,25 @@ automatic memory management with incremental garbage collection, making it ideal
for configuration, scripting, and rapid prototyping.")
(license license:x11)))
+(define-public lua-5.2
+ (package (inherit lua)
+ (version "5.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.lua.org/ftp/lua-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0jwznq0l8qg9wh5grwg07b5cy3lzngvl5m2nl1ikp6vqssmf9qmr"))
+ (patches (search-patches "lua-pkgconfig.patch"
+ "lua-liblua-so.patch"))))))
+
(define-public lua-5.1
(package (inherit lua)
(version "5.1.5")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.lua.org/ftp/lua-"
+ (uri (string-append "https://www.lua.org/ftp/lua-"
version ".tar.gz"))
(sha256
(base32 "0cskd4w0g6rdm2q8q3i4n1h3j8kylhs3rq8mxwl9vwlmlxbgqh16"))