summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/lua.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm29
1 files changed, 6 insertions, 23 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 7cadba6392..22dc7c6bc4 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Simon South <simon@simonsouth.net>
;;; Copyright © 2020 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1140,7 +1141,7 @@ shell command executions.")
(inputs
`(("boost" ,boost)
("boost-static" ,boost-static)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-7)
;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
;; fork. Emilua is severely affected by this limit, so the upstream package
;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
@@ -1169,7 +1170,7 @@ enabled.")
(define-public fennel
(package
(name "fennel")
- (version "0.9.1")
+ (version "1.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1178,11 +1179,7 @@ enabled.")
(file-name (git-file-name name version))
(sha256
(base32
- "07qgycf5cxm9zcc4fgpgvplg95ndavh3ynpdjpvzkikzbnyj7xia"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file "fennelview.lua") #t))))
+ "0d4rpf0f2aqxlca3kxrbhjjhf1knhiz8ccwlx8xid05mc16la70y"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
@@ -1191,28 +1188,14 @@ enabled.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-before 'build 'patch-lua-calls
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((lua (search-input-file inputs "/bin/lua")))
- (setenv "LUA" lua)
- (substitute* "old/launcher.lua"
- (("/usr/bin/env lua") lua))
- #t)))
(add-after 'build 'patch-fennel
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "fennel"
(("/usr/bin/env .*lua")
- (search-input-file inputs "/bin/lua")))
- #t))
+ (search-input-file inputs "/bin/lua")))))
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check))
- (add-after 'install 'install-manpage
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "fennel.1"
- (string-append (assoc-ref outputs "out")
- "/share/man/man1"))
- #t)))))
+ (assoc-ref %standard-phases 'check)))))
(inputs `(("lua" ,lua)))
(home-page "https://fennel-lang.org/")
(synopsis "Lisp that compiles to Lua")