summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-25 10:08:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-25 11:55:37 +0200
commit18a512528de2aa5de85eb32f0305692cbf85231f (patch)
tree7491476bd4ed8783f9f951b3f4b135c896bee70a /gnu/packages/lua.scm
parent60021f2afaed1c2493017b8de43f13fcd909d48e (diff)
downloadguix-patches-18a512528de2aa5de85eb32f0305692cbf85231f.tar
guix-patches-18a512528de2aa5de85eb32f0305692cbf85231f.tar.gz
gnu: fennel: Install manpage.
* gnu/packages/lua.scm (fennel)[arguments]: Add phase to install manpage.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index e4b3818faa..0100ed2dd3 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1094,7 +1094,13 @@ shell command executions.")
#t))
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check)))))
+ (assoc-ref %standard-phases 'check))
+ (add-after 'install 'install-manpage
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "fennel.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1"))
+ #t)))))
(inputs `(("lua" ,lua)))
(home-page "https://fennel-lang.org/")
(synopsis "Lisp that compiles to Lua")