summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 05:09:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 05:44:11 +0100
commitf942c09b663c3a48a1ae22ae96b69aabc323fd31 (patch)
tree56b61be3614e32329c9e10c7db9b1c4c21bc39f4 /gnu/packages/lsof.scm
parent2bf502138c9c8cad945866061772fe0e1f4b7175 (diff)
downloadguix-patches-f942c09b663c3a48a1ae22ae96b69aabc323fd31.tar
guix-patches-f942c09b663c3a48a1ae22ae96b69aabc323fd31.tar.gz
gnu: lsof: Cross-compile.
* gnu/packages/lsof.scm (lsof)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 77d93e99c7..b317902ee7 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -24,6 +24,7 @@
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages groff)
#:use-module (gnu packages perl))
@@ -51,7 +52,7 @@
(modify-phases %standard-phases
(replace 'configure
(lambda _
- (setenv "LSOF_CC" "gcc")
+ (setenv "LSOF_CC" ,(cc-for-target))
(setenv "LSOF_MAKE" "make")
;; By default, the makefile captures the output of 'uname -a'.