summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-30 14:29:42 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-30 23:50:40 +0100
commitd70478da2b878350450b976686f29712c06745f3 (patch)
treeae6ab98bf999a8b13d3edac4ee068da5008d7b80 /gnu/packages/lsof.scm
parent69dc3e5237d69479a7ea71ca8fa9c941d9f6e350 (diff)
downloadguix-patches-d70478da2b878350450b976686f29712c06745f3.tar
guix-patches-d70478da2b878350450b976686f29712c06745f3.tar.gz
gnu: lsof: Don't capture details about the build machine's kernel.
* gnu/packages/lsof.scm (lsof)[arguments]: In 'configure' phase, set "LSOF_SYSINFO" environment variable.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 311e244608..e29f3b4569 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +69,13 @@
(lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
+
+ ;; By default, the makefile captures the output of 'uname -a'.
+ ;; Provide a fixed output instead to make builds reproducible.
+ (setenv "LSOF_SYSINFO"
+ (string-append "GNU/" (utsname:sysname (uname))
+ " (GNU Guix)"))
+
(invoke "./Configure" "linux")
#t))
(add-after 'configure 'patch-timestamps