summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 02:05:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 06:00:30 +0100
commitc2799070caf305a4c88e9a77fc36632069811f56 (patch)
tree0a60454eff794724da9a1a581bf819f5c25fe2c4 /gnu/packages/lsof.scm
parentb7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e (diff)
downloadguix-patches-c2799070caf305a4c88e9a77fc36632069811f56.tar
guix-patches-c2799070caf305a4c88e9a77fc36632069811f56.tar.gz
gnu: lsof: Remove build timestamp.
* gnu/packages/lsof.scm (lsof)[arguments]: Add ‘patch-timestamps’ phase.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index fcd5c2e1c7..7f365f32c1 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -71,6 +71,10 @@
(setenv "LSOF_MAKE" "make")
(invoke "./Configure" "linux")
#t))
+ (add-after 'configure 'patch-timestamps
+ (lambda _
+ (substitute* "Makefile"
+ (("`date`") "`date --date=@1`"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))