summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 03:47:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 05:44:10 +0100
commit518b21e058f9ccf23257a2afe1bbace280c5fe1d (patch)
tree5ebc5d59016a758d12cb6affe9a6f396a0dd6c33 /gnu/packages/lsof.scm
parent83371ccddd05e1eeee5ead3194fdec53ec089ca2 (diff)
downloadguix-patches-518b21e058f9ccf23257a2afe1bbace280c5fe1d.tar
guix-patches-518b21e058f9ccf23257a2afe1bbace280c5fe1d.tar.gz
gnu: lsof: Update to 4.94.0.
* gnu/packages/lsof.scm (lsof): Update to 4.94.0. [source]: Switch to new git upstream. [native-inputs]: Add groff. [arguments]: Remove custom 'unpack phase. Add a 'build-man-page phase. Remove the upstreamed glibc@2.28 test fix.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm55
1 files changed, 18 insertions, 37 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 34ad0f03d5..ad3dfbd2df 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -22,49 +22,31 @@
(define-module (gnu packages lsof)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages perl))
(define-public lsof
(package
(name "lsof")
- (version "4.91")
+ (version "4.94.0")
(source
(origin
- (method url-fetch)
- (uri
- (apply append
- (map
- (lambda (mirror-uri)
- (let ((tarball (string-append name "_" version ".tar.bz2")))
- (list
- (string-append mirror-uri "/" tarball)
- ;; Upon every new release, the previous one is moved here:
- (string-append mirror-uri "/OLD/" tarball))))
- (list
- "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
-
- ;; Add mirrors because the canonical FTP server at purdue.edu
- ;; bails out when it cannot do a reverse DNS lookup, as noted
- ;; at <https://people.freebsd.org/~abe/>.
- "ftp://ftp.fu-berlin.de/pub/unix/tools/lsof/"
- (string-append "http://www.mirrorservice.org/sites/"
- "lsof.itap.purdue.edu/pub/tools/unix/lsof")
- (string-append "ftp://ftp.mirrorservice.org/sites/"
- "lsof.itap.purdue.edu/pub/tools/unix/lsof")))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lsof-org/lsof")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "18sh4hbl9jw2szkf0gvgan8g13f3g4c6s2q9h3zq5gsza9m99nn9"))))
+ (base32 "0yxv2jg6rnzys49lyrz9yjb4knamah4xvlqj596y6ix3vm4k3chp"))))
(build-system gnu-build-system)
- (native-inputs `(("perl" ,perl)))
+ (native-inputs
+ `(("groff" ,groff) ; for soelim
+ ("perl" ,perl)))
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'unpack
- (lambda* (#:key source #:allow-other-keys)
- (let ((unpack (assoc-ref %standard-phases 'unpack)))
- (unpack #:source source)
- (unpack #:source (car (find-files "." "\\.tar$"))))))
(replace 'configure
(lambda _
(setenv "LSOF_CC" "gcc")
@@ -83,14 +65,13 @@
(substitute* "Makefile"
(("`date`") "`date --date=@1`"))
#t))
+ (add-after 'build 'build-man-page
+ (lambda _
+ (with-output-to-file "lsof.8"
+ (lambda _ (invoke "soelim" "Lsof.8")))
+ #t))
(add-before 'check 'disable-failing-tests
(lambda _
- ;; In libc 2.28, the 'major' and 'minor' macros are provided by
- ;; <sys/sysmacros.h> only so include it.
- (substitute* "tests/LTlib.c"
- (("#ifndef lint")
- "#include <sys/sysmacros.h>\n\n#ifndef lint"))
-
(substitute* "tests/Makefile"
;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
(("(STDTST=.*) LTsock" _ prefix) prefix)