summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 00:26:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:13 -0500
commit46ecaa46b599b4b52faa2836180c26d296f3cbe8 (patch)
tree3519248fefa8f16ff01194aeb062acc811617c62 /gnu/packages/lsof.scm
parent781f475bbac4e73848f68cb9f420a7283ec17c16 (diff)
downloadguix-patches-46ecaa46b599b4b52faa2836180c26d296f3cbe8.tar
guix-patches-46ecaa46b599b4b52faa2836180c26d296f3cbe8.tar.gz
gnu: lsof: Disable the LTlock test.
Fixes <https://issues.guix.gnu.org/44953>. * gnu/packages/lsof.scm (lsof)[phases]: Remove trailing #t. {disable-failing-tests}: Disable the LTlock test.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index b317902ee7..7ded6ee726 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,26 +62,25 @@
(string-append "GNU/" (utsname:sysname (uname))
" (GNU Guix)"))
- (invoke "./Configure" "linux")
- #t))
+ (invoke "./Configure" "linux")))
(add-after 'configure 'patch-timestamps
(lambda _
(substitute* "Makefile"
- (("`date`") "`date --date=@1`"))
- #t))
+ (("`date`") "`date --date=@1`"))))
(add-after 'build 'build-man-page
(lambda _
(with-output-to-file "lsof.8"
- (lambda _ (invoke "soelim" "Lsof.8")))
- #t))
+ (lambda _ (invoke "soelim" "Lsof.8")))))
(add-before 'check 'disable-failing-tests
(lambda _
(substitute* "tests/Makefile"
;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
(("(STDTST=.*) LTsock" _ prefix) prefix)
- ;; Fails without access to a remote NFS server.
- (("(OPTTST=.*) LTnfs" _ prefix) prefix))
- #t))
+ ;; LTnfs fails without access to a remote NFS server, and LTlock
+ ;; fails when run on a Btrfs file system (see:
+ ;; https://github.com/lsof-org/lsof/issues/152).
+ (("OPTTST=[[:space:]]*LTbigf LTdnlc LTlock LTnfs")
+ "OPTTST = LTbigf LTdnlc"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -90,14 +90,12 @@
(invoke "./Add2TestDB")
;; The ‘standard’ tests suggest running ‘optional’ ones as well.
- (invoke "make" "standard" "optional")))
- #t))
+ (invoke "make" "standard" "optional")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(install-file "lsof" (string-append out "/bin"))
- (install-file "lsof.8" (string-append out "/share/man/man8")))
- #t)))))
+ (install-file "lsof.8" (string-append out "/share/man/man8"))))))))
(synopsis "Display information about open files")
(description
"Lsof stands for LiSt Open Files, and it does just that.