summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-06-14 14:18:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-15 15:35:02 +0200
commitce9cf64b787aeb063823f0e9056db5b644ef5f75 (patch)
treecb936a6dfd3a5908608aac7796a3f66b1443419a /gnu/packages/logging.scm
parentba6a996eacab58b1791feb69bc460777352d5039 (diff)
downloadguix-patches-ce9cf64b787aeb063823f0e9056db5b644ef5f75.tar
guix-patches-ce9cf64b787aeb063823f0e9056db5b644ef5f75.tar.gz
gnu: Add log4cpp.
* gnu/packages/logging.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
new file mode 100644
index 0000000000..68af09e08c
--- /dev/null
+++ b/gnu/packages/logging.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages logging)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+(define-public log4cpp
+ (package
+ (name "log4cpp")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/log4cpp/log4cpp-"
+ (version-major+minor version) ".x%20%28new%29"
+ "/log4cpp-" (version-major+minor version)
+ "/log4cpp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1l5yz5rfzzv6g3ynrj14mxfsk08cp5h1ssr7d74hjs0accrg7arm"))))
+ (build-system gnu-build-system)
+ (synopsis "Log library for C++")
+ (description
+ "Log4cpp is library of C++ classes for flexible logging to files, syslog,
+IDSA and other destinations. It is modeled after the Log4j Java library,
+staying as close to their API as is reasonable.")
+ (home-page "http://log4cpp.sourceforge.net/")
+ (license license:lgpl2.1+)))