summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-04 13:44:23 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-04 14:30:00 +0200
commitb7506f74dffd86b93a07ef2c6dfc6517897afea6 (patch)
treea596e5cf266f5ef5645c7c1bd0c320a71d68aef1 /gnu/packages/logging.scm
parent6c17422eace097aceac4b5994f0343bcbed6e3ab (diff)
downloadguix-patches-b7506f74dffd86b93a07ef2c6dfc6517897afea6.tar
guix-patches-b7506f74dffd86b93a07ef2c6dfc6517897afea6.tar.gz
gnu: glog: Fix name demangling for GCC 5.
* gnu/packages/patches/glog-gcc-5-demangling.patch: New file. * gnu/packages/logging.scm (glog)[sources]: Add it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index c40d6ebbaf..d28094c3a8 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +24,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages perl)
#:use-module (gnu packages autotools))
@@ -62,7 +63,8 @@ staying as close to their API as is reasonable.")
(sha256
(base32
"0ym5g15m7c8kjfr2c3zq6bz08ghin2d1r1nb6v2vnkfh1vn945x1"))
- (file-name (string-append name "-" version "-checkout"))))
+ (file-name (string-append name "-" version "-checkout"))
+ (patches (search-patches "glog-gcc-5-demangling.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl) ;for tests