summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-05-01 20:22:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-05-01 23:59:29 +0200
commit99aa2dce5d376b6612aab0971985f6320c03ecd2 (patch)
tree306f5a9077c0d64493d8c5ae869453fcd2495ef5 /gnu/packages/logging.scm
parent6fdeb324a049bc9398658ff59ee94d3b88a8e469 (diff)
downloadguix-patches-99aa2dce5d376b6612aab0971985f6320c03ecd2.tar
guix-patches-99aa2dce5d376b6612aab0971985f6320c03ecd2.tar.gz
gnu: Add tailon.
* gnu/packages/logging.scm (tailon): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index d28094c3a8..2523d65f61 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -24,8 +24,10 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages autotools))
(define-public log4cpp
@@ -90,3 +92,27 @@ helper macros. You can log a message by simply streaming things to log at a
particular severity level. It allows logging to be controlled from the
command line.")
(license license:bsd-3)))
+
+(define-public tailon
+ (package
+ (name "tailon")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "08clrwpfdxcv2z2b5ardpmim4alahbw4l7631dhw62xhbcf6wjzz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-pyyaml" ,python-pyyaml)
+ ("python-sockjs-tornado" ,python-sockjs-tornado)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://tailon.readthedocs.io/")
+ (synopsis
+ "Webapp for looking at and searching through log files")
+ (description
+ "Tailon provides a web interface around the tail, grep, awk and sed
+commands, displaying the results via a web interface.")
+ (license license:bsd-3)))