summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-05-16 20:40:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-05-17 16:50:41 +0200
commit872a6fd98868d345443f04efdfd974d148c57f9d (patch)
tree20d38361e2c9fc9c0fd87618ac505b5ab0b0e77d /gnu/packages/logging.scm
parent411ba511893feca223656122059cb12378b95c91 (diff)
downloadguix-patches-872a6fd98868d345443f04efdfd974d148c57f9d.tar
guix-patches-872a6fd98868d345443f04efdfd974d148c57f9d.tar.gz
gnu: tailon: Use absolute paths for commands.
* gnu/packages/logging.scm (tailon)[arguments]: Patch commands.py to reference grep, awk, sed and tail by absolute paths. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 2523d65f61..7501f1e5db 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -109,6 +109,21 @@ command line.")
`(("python-pyyaml" ,python-pyyaml)
("python-sockjs-tornado" ,python-sockjs-tornado)
("python-tornado" ,python-tornado)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-commands.py
+ (lambda args
+ (substitute* "tailon/commands.py"
+ (("self\\.first_in_path\\('grep'\\)")
+ (string-append"'" (which "grep") "'"))
+ (("self\\.first_in_path\\('gawk', 'awk'\\)")
+ (string-append"'" (which "gawk") "'"))
+ (("self\\.first_in_path\\('gsed', 'sed'\\)")
+ (string-append"'" (which "sed") "'"))
+ (("self\\.first_in_path\\('gtail', 'tail'\\)")
+ (string-append"'" (which "tail") "'")))
+ #t)))))
(home-page "https://tailon.readthedocs.io/")
(synopsis
"Webapp for looking at and searching through log files")