summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-06 10:10:17 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-06 10:18:21 +0200
commit722c17992e85189decb5cffb0e62c622294dc5fa (patch)
tree3a7b1ae066a4fa8b7afeb16078f999bab09928ca /gnu/packages/logging.scm
parentdf1f031d146357123219416b9fa81c51c9032246 (diff)
downloadguix-patches-722c17992e85189decb5cffb0e62c622294dc5fa.tar
guix-patches-722c17992e85189decb5cffb0e62c622294dc5fa.tar.gz
gnu: glog: Update to 0.5.0.
* gnu/packages/logging.scm (glog): Update to 0.5.0. [build-system]: Switch to 'cmake-build-system'. [arguments]: Remove 'disable-signal-tests' phase.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 6a4975e435..34dc124cb6 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,7 +77,7 @@ staying as close to their API as is reasonable.")
(define-public glog
(package
(name "glog")
- (version "0.4.0")
+ (version "0.5.0")
(home-page "https://github.com/google/glog")
(source (origin
(method git-fetch)
@@ -84,19 +85,9 @@ staying as close to their API as is reasonable.")
(commit (string-append "v" version))))
(sha256
(base32
- "1xd3maiipfbxmhc9rrblc5x52nxvkwxp14npg31y5njqvkvzax9b"))
+ "17014q25c99qyis6l3fwxidw6222bb269fdlr74gn7pzmzg4lvg3"))
(file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-signal-tests
- (lambda _
- ;; XXX: This test fails on non x86_64. See e.g.
- ;; https://github.com/google/glog/issues/219 and
- ;; https://github.com/google/glog/issues/256.
- (substitute* "Makefile"
- (("\tsignalhandler_unittest_sh") "\t$(EMPTY)"))
- #t)))))
+ (build-system cmake-build-system)
(native-inputs
`(("perl" ,perl) ;for tests
("autoconf" ,autoconf)