summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-18 23:44:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-19 00:02:09 +0200
commit4678cc46a4c1e0538402d8df6d85d3caedc7f00b (patch)
tree93ec8605f99506d3af2a3bf1f5655c2526683f78 /gnu/packages/logging.scm
parent262f904ebd2087a2f285b1c381ac32195c832c9e (diff)
downloadguix-patches-4678cc46a4c1e0538402d8df6d85d3caedc7f00b.tar
guix-patches-4678cc46a4c1e0538402d8df6d85d3caedc7f00b.tar.gz
gnu: glog: Update to 0.4.0.
* gnu/packages/patches/glog-gcc-5-demangling.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/logging.scm (glog): Update to 0.4.0. [source]: Use GIT-FETCH. [arguments]: Remove.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm30
1 files changed, 6 insertions, 24 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 24a47567d0..42404636f6 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -64,40 +64,22 @@ staying as close to their API as is reasonable.")
(define-public glog
(package
(name "glog")
- (version "0.3.5")
+ (version "0.4.0")
(home-page "https://github.com/google/glog")
(source (origin
- (method url-fetch)
- (uri (string-append home-page "/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
(sha256
(base32
- "1q6ihk2asbx95a56kmyqwysq1x3grrw9jwqllafaidf0l84f903m"))
- (file-name (string-append name "-" version ".tar.gz"))
- (patches (search-patches "glog-gcc-5-demangling.patch"))))
+ "1xd3maiipfbxmhc9rrblc5x52nxvkwxp14npg31y5njqvkvzax9b"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl) ;for tests
("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)))
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'add-automake-files
- (lambda _
- ;; The 'test-driver' file is a dangling symlink to
- ;; /usr/share/automake; replace it. We can't just run
- ;; 'automake -ac' because it complains about version
- ;; mismatch, so run the whole thing.
- (delete-file "test-driver")
- (delete-file "configure") ;it's read-only
- (invoke "autoreconf" "-vfi")))
- (add-before 'check 'disable-signal-tests
- (lambda _
- ;; See e.g. https://github.com/google/glog/issues/219
- ;; and https://github.com/google/glog/issues/256
- (substitute* "Makefile"
- (("\tsignalhandler_unittest_sh") "\t$(EMPTY)"))
- #t)))))
(synopsis "C++ logging library")
(description
"Google glog is a library that implements application-level logging.