summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-24 17:45:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-24 17:45:18 +0200
commit3c74a74ea2814bca25257f8211b8084a3cc1a3b9 (patch)
treef4fc1a6d5d12c29d59b0b48335254bd30fb4b424 /gnu/packages/logging.scm
parent2133f193787c7ca0f5e18aee96657756c5fb1384 (diff)
downloadguix-patches-3c74a74ea2814bca25257f8211b8084a3cc1a3b9.tar
guix-patches-3c74a74ea2814bca25257f8211b8084a3cc1a3b9.tar.gz
gnu: glog: Update to 0.3.5.
* gnu/packages/logging.scm (glog): Update to 0.3.5. [source]: Switch to tarball download.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 7501f1e5db..b2b0582aee 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -55,17 +55,15 @@ staying as close to their API as is reasonable.")
(define-public glog
(package
(name "glog")
- (version "0.3.4")
+ (version "0.3.5")
(home-page "https://github.com/google/glog")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (string-append home-page "/archive/v" version ".tar.gz"))
(sha256
(base32
- "0ym5g15m7c8kjfr2c3zq6bz08ghin2d1r1nb6v2vnkfh1vn945x1"))
- (file-name (string-append name "-" version "-checkout"))
+ "1q6ihk2asbx95a56kmyqwysq1x3grrw9jwqllafaidf0l84f903m"))
+ (file-name (string-append name "-" version ".tar.gz"))
(patches (search-patches "glog-gcc-5-demangling.patch"))))
(build-system gnu-build-system)
(native-inputs