summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:27:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:03 +0200
commit2f6a93472264a38280335454b3f81f36bdda5479 (patch)
treee3ae1d87f71d8f4d9af061439dec62352ad7984b /gnu/packages/logging.scm
parent5a13cf3d1dc635707b82a4412aa116ca49463191 (diff)
downloadguix-patches-2f6a93472264a38280335454b3f81f36bdda5479.tar
guix-patches-2f6a93472264a38280335454b3f81f36bdda5479.tar.gz
gnu: glog: Return #t from all phases.
* gnu/packages/logging.scm (glog)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index f50a2f1cbb..665b384b95 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -86,7 +86,7 @@ staying as close to their API as is reasonable.")
;; mismatch, so run the whole thing.
(delete-file "test-driver")
(delete-file "configure") ;it's read-only
- (zero? (system* "autoreconf" "-vfi"))))
+ (invoke "autoreconf" "-vfi")))
(add-before 'check 'disable-signal-tests
(lambda _
;; See e.g. https://github.com/google/glog/issues/219