summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2017-12-07 16:15:38 -0600
committerEric Bavier <bavier@member.fsf.org>2018-01-04 15:34:47 -0600
commit17e1e21603e7cba622cf4ec41c0e1467972fd449 (patch)
tree207307d0f3aa59e075317f88430b2d62c081cf32 /gnu/packages/logging.scm
parent72687ca5d2d8d1dd55b152823a164606fa421d9c (diff)
downloadguix-patches-17e1e21603e7cba622cf4ec41c0e1467972fd449.tar
guix-patches-17e1e21603e7cba622cf4ec41c0e1467972fd449.tar.gz
gnu: glog: Disable signal-handler unit tests.
* gnu/packages/logging.scm (glog)[arguments]: Add 'disable-signal-tests' phase.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 6f9056d8f2..713435c6a7 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,7 +85,14 @@ staying as close to their API as is reasonable.")
;; mismatch, so run the whole thing.
(delete-file "test-driver")
(delete-file "configure") ;it's read-only
- (zero? (system* "autoreconf" "-vfi")))))))
+ (zero? (system* "autoreconf" "-vfi"))))
+ (add-before 'check 'disable-signal-tests
+ (lambda _
+ ;; See e.g. https://github.com/google/glog/issues/219
+ ;; and https://github.com/google/glog/issues/256
+ (substitute* "Makefile"
+ (("\tsignalhandler_unittest_sh") "\t$(EMPTY)"))
+ #t)))))
(synopsis "C++ logging library")
(description
"Google glog is a library that implements application-level logging.