summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-17 22:54:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-17 22:54:03 +0100
commitf8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d (patch)
treee03d747fa9fc11578f0fe55056421c99413de977 /gnu/packages/llvm.scm
parent0a41123f01d5d2466d6f533be3644ac8c9a2bdf9 (diff)
downloadguix-patches-f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.tar
guix-patches-f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.tar.gz
gnu: mesa: Stay on RTTI-less LLVM.
* gnu/packages/llvm.scm (llvm-without-rtti): New public variable. * gnu/packages/gl.scm (mesa)[inputs]: Use that instead of LLVM.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index beca92650e..d237a05a84 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -91,6 +91,26 @@ languages is in development. The compiler infrastructure includes mirror sets
of programming tools as well as libraries with equivalent functionality.")
(license license:ncsa)))
+;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
+;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890. Update users of
+;; this in the next rebuild cycle.
+(define-public llvm-without-rtti
+ (package
+ (inherit llvm)
+ (arguments
+ `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
+ "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
+ "-DBUILD_SHARED_LIBS:BOOL=TRUE"
+ "-DLLVM_ENABLE_FFI:BOOL=TRUE"
+ "-DLLVM_INSTALL_UTILS=ON")
+ #:build-type "Release"
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'shared-lib-workaround
+ (lambda _
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (getcwd) "/lib"))
+ #t)))))))
+
(define* (clang-runtime-from-llvm llvm hash
#:optional (patches '()))
(package