summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 16:04:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 16:04:53 +0100
commitf42bfc7a99b1e152cd014fca069083527f10665c (patch)
treec6bf1a84195b4c9c975f53f539a2840cabe98bd8 /gnu/packages/llvm.scm
parent56c833ea287f8f6d3c72f8bddc314960c0164d64 (diff)
downloadguix-patches-f42bfc7a99b1e152cd014fca069083527f10665c.tar
guix-patches-f42bfc7a99b1e152cd014fca069083527f10665c.tar.gz
gnu: clang: Switch to 'C_INCLUDE_PATH' & co.
* gnu/packages/llvm.scm (clang-from-llvm)[native-search-paths]: Remove "CPATH", and add "C_INCLUDE_PATH" and "CPLUS_INCLUDE_PATH".
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 1286fe521b..3909039f3e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -339,9 +339,12 @@ compiler. In LLVM this library is called \"compiler-rt\".")
;; Clang supports the same environment variables as GCC.
(native-search-paths
(list (search-path-specification
- (variable "CPATH")
+ (variable "C_INCLUDE_PATH")
(files '("include")))
(search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include/c++" "include")))
+ (search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))