summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-25 00:39:14 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-25 02:01:01 +0100
commitac97dce1d24e3c986c580a76148deafdf52fccdb (patch)
tree87c3627bc0ad374f77e33c1c51124475a0cb883f /gnu/packages/llvm.scm
parenta431b035008e5fe1ea844f743ff993cb56c7795e (diff)
downloadguix-patches-ac97dce1d24e3c986c580a76148deafdf52fccdb.tar
guix-patches-ac97dce1d24e3c986c580a76148deafdf52fccdb.tar.gz
gnu: check, llvm: Use HTTPS for llvm.org home pages.
* gnu/packages/check.scm (python-lit)[home-page]: Use HTTPS. * gnu/packages/llvm.scm (llvm, clang, clang-runtime)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 4702a342a0..b13a33ff1f 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -76,7 +76,7 @@
(setenv "LD_LIBRARY_PATH"
(string-append (getcwd) "/lib"))
#t)))))
- (home-page "http://www.llvm.org")
+ (home-page "https://www.llvm.org")
(synopsis "Optimizing compiler infrastructure")
(description
"LLVM is a compiler infrastructure designed for compile-time, link-time,
@@ -116,7 +116,7 @@ of programming tools as well as libraries with equivalent functionality.")
`(;; Don't use '-g' during the build to save space.
#:build-type "Release"
#:tests? #f)) ; Tests require gtest
- (home-page "http://compiler-rt.llvm.org")
+ (home-page "https://compiler-rt.llvm.org")
(synopsis "Runtime library for Clang/LLVM")
(description
"The \"clang-runtime\" library provides the implementations of run-time
@@ -125,7 +125,7 @@ and C++ source code to interface with the \"sanitization\" passes of the clang
compiler. In LLVM this library is called \"compiler-rt\".")
(license license:ncsa)
- ;; <http://compiler-rt.llvm.org/> doesn't list MIPS as supported.
+ ;; <https://compiler-rt.llvm.org/> doesn't list MIPS as supported.
(supported-systems (delete "mips64el-linux" %supported-systems))))
(define* (clang-from-llvm llvm clang-runtime hash
@@ -200,7 +200,7 @@ compiler. In LLVM this library is called \"compiler-rt\".")
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (home-page "http://clang.llvm.org")
+ (home-page "https://clang.llvm.org")
(synopsis "C language family frontend for LLVM")
(description
"Clang is a compiler front end for the C, C++, Objective-C and