summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-07 18:11:40 +0100
committerMarius Bakke <marius@gnu.org>2022-01-08 11:38:46 +0100
commita05e573d60bf64129abf4d4e5f27355c84ebb2ee (patch)
tree76f210a5d56e3b9d8e1f7e8dec419a8ef7143649 /gnu/packages/llvm.scm
parent3191dacc6631759ee51718763bcd4e8c9b12278c (diff)
downloadguix-patches-a05e573d60bf64129abf4d4e5f27355c84ebb2ee.tar
guix-patches-a05e573d60bf64129abf4d4e5f27355c84ebb2ee.tar.gz
gnu: lld: Update to 13.0.0.
* gnu/packages/llvm.scm (lld): Update to 13.0.0. [inputs]: Change from LLVM-12 to LLVM-13.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 1344c1a46f..f2c1dc18fd 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1122,20 +1122,20 @@ of programming tools as well as libraries with equivalent functionality.")
(define-public lld
(package
(name "lld")
- (version "12.0.1")
+ (version "13.0.0")
(source (origin
(method url-fetch)
(uri (llvm-uri "lld" version))
(sha256
(base32
- "0qg3fgc7wj34hdkqn21y03zcmsdd01szhhm1hfki63iifrm3y2v9"))))
+ "11lkwv4jy35z2f3zcpv7hbbk9v9gpavfvxlif8265zv4rl5r1l90"))))
(build-system cmake-build-system)
(native-inputs
;; Note: check <https://bugs.llvm.org/show_bug.cgi?id=49228> to see
;; whether this is still necessary.
(list libunwind-headers))
(inputs
- (list llvm-12))
+ (list llvm-13))
(arguments
`(#:build-type "Release"
;; TODO: Tests require the lit tool, which isn't installed by the LLVM